【アライドスイッチ】インターフェース基本設定について

ネットワーク

対象環境

  • ファームウェアバージョン 5.5.0-1.3

インターフェースの無効化/有効化

インターフェースの無効化(シャットダウン)は対象インターフェースモードに移行後以下コマンドで行います。

  • shutdown

設定例:

switch(config)# interface port1.0.1
switch(config-if)# shutdown

インターフェースの有効化(シャットダウン解除)は対象インターフェースモードに移行後以下コマンドで行います。

  • no shutdown

設定例:

switch(config)# interface port1.0.1
switch(config-if)# no shutdown

Speed と Duplex の設定

インターフェースの Speed と Duplex の設定は対象インターフェースモードに移行後以下コマンドで行います。

  • speed SPEED
    • SPEED:Speed を以下から指定する
      • 10:10Mbps
      • 100:100Mbps
      • 1000:1000Mbps(1Gbps)
      • auto:オートネゴシエーション(デフォルト)
  • duplex DUPLEX
    • DUPLEX:Duplex を以下から指定する
      • half:半二重
      • full:全二重
      • auto:オートネゴシエーション(デフォルト)

設定例:

switch(config)# interface port1.0.1
switch(config-if)# speed 100
switch(config-if)# duplex full

VLAN 設定

アクセスポート設定

対象ポートをアクセスポートと設定する場合は対象インターフェースモードにて以下コマンドで行います。

  1. switchport mode access
  2. switchport access vlan VLAN
    • VLAN:1-4094 から指定する

設定例:

switch(config)# interface port1.0.1
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan 100

トランクポート設定

対象ポートをトランクポート(タグ VLAN ポート)と設定する場合は対象インターフェースモードにて以下コマンドで行います。

  1. switchport mode trunk
  2. switchport trunk allowed vlan add VLAN
    • VLAN:許可する VLAN リストを指定。カンマ、ハイフンを使用した表記が可能
      • 指定する VLAN は vlan コマンドで定義済みのものでなくてはならない

設定例:

switch(config)# interface port1.0.1
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk allowed vlan add 200,300

VLAN を定義する例:VLAN 10,20,30,40-49 をまとめて定義する場合

switch(config)# vlan database
switch(config-vlan)# vlan 10,20,30,40-49

ネイティブ VLAN の設定

対象ポートのネイティブ VLAN を設定する場合は対象インターフェースモードにて以下コマンドで行います。

  • switchport trunk native vlan VLAN
    • VLAN:1-4094 または none から指定する

IP アドレスの設定

IP アドレスの設定は対象インターフェースモードに移行後以下コマンドで行います。

  • ip address A.B.C.D/M
    • A.B.C.D/M:IP アドレスとマスク長を指定

設定例:

switch(config)# interface vlan100
switch(config-if)# ip address 10.20.30.1/24

IP アドレス設定の削除は以下コマンドで行います。

  • no ip address

設定例:

switch(config)# interface vlan100
switch(config-if)# no ip address

―――――――――――――

タイトルとURLをコピーしました