【Cisco】HSRP の基本設定とインターフェーストラッキング設定

ネットワーク

HSRP 基本設定

HSRP を構築するために、最低限必要な設定は以下の通りです。

interface "IF-NAME"                   #HSRP を設定する対象インターフェースを指定
 ip address "ADDRESS" "MASK"          #インターフェースの実 IP アドレスを設定
 standby "GROUPNUM" ip "Virtual-IP"   #HSRP のグループ番号および仮想 IP アドレスを設定
  • "IF-NAME":HSRP を設定する対象インターフェース
  • "GROUPNUM":HSRP グループ番号。HSRP を構成する際にペアとなる機器と同じ番号とする
  • "Virtual-IP":仮想 IP アドレス。他ホストからはこの IP へアクセスすることになる

HSRP コンフィグのデフォルト値

HSRP では、以下のようにデフォルト値が決まっています。値の変更が必要な項目については明示的に設定します。

項目デフォルト値備考
HSRP バージョンVersion 1
HSRP グループ未設定
スタンバイ グループ番号0HSRP version 1 の場合は 0 ~ 255
HSRP version 2 の場合は 0 ~ 4095
スタンバイ MAC アドレス0000.0c07.acXX
XX は、HSRP グループ番号
スタンバイ プライオリティ100プライオリティの高い機器がアクティブとなる
スタンバイでのインターフェイス
プライオリティの追跡
10トラッキング設定によるプライオリティの減少幅
スタンバイ hello 時間3 秒hello パケット間隔
スタンバイ ホールドタイム10 秒アクティブルータの役割を引き継ぐまでの遅延時間
hello パケット間隔の3倍にすること

プライオリティの設定

プライオリティの高い機器がアクティブとなります。

interface "IF-NAME"                       #HSRP を設定する対象インターフェースを指定
 standby "GROUPNUM" priority "PRIORITY"   #HSRP のグループ番号を指定しプライオリティを設定
  • "GROUPNUM":HSRP グループ番号。HSRP を構成する際にペアとなる機器と同じ番号とする
  • "PRIORITY":プライオリティ

Hello タイマとホールドタイムの設定

interface "IF-NAME"                                 #HSRP を設定する対象インターフェースを指定
 standby "GROUPNUM" timers "HELLOTIME" "HOLDTIME"   #HSRP のグループ番号を指定しhelle間隔,ホールドタイムを設定
  • "GROUPNUM":HSRP グループ番号。HSRP を構成する際にペアとなる機器と同じ番号とする
  • "HELLOTIME":hello パケット間隔(秒)
  • "HOLDTIME":ホールドタイム(秒)。hello パケット間隔の3倍にすること

プリエンプト設定

プリエンプト設定を行うと、プライオリティの高いアクティブ機が障害から復旧した際に、その機器へ自動で切り戻しされます。この設定は HSRP を構成する機器のうちプライオリティの高い機器側でのみ行えば十分ですが、すべての機器で設定していても問題ありません。

interface "IF-NAME"            #HSRP を設定する対象インターフェースを指定
 standby "GROUPNUM" preempt    #HSRP のグループ番号を指定しプリエンプトを設定

インターフェースのトラッキング設定

以下のような構成の場合、上側のリンクに障害が発生した場合もアクティブ機の切り替えを行いたいですが、デフォルトでは切り替わりません。

このようなときはトラッキングという設定を行います。

監視対象のインターフェースを設定して、そのインターフェースがダウンしたときにプライオリティを減じることでアクティブ機を切り替えます。

track "TRACKNUM" interface "TR-IF-NAME" line-protocol       #トラッキング番号と監視対象インターフェースを指定

interface "IF-NUM"                                         #HSRP を設定する対象インターフェースを指定
 standby "GROUPNUM" track "TRACKNUM" decrement "DECVALUE"  #HSRP のグループ番号を指定しトラッキング番号とプライオリティの減少幅を指定
  • "TRACKNUM":トラッキング番号を指定
  • "TR-IF-NAME":監視対象インターフェース名を指定
  • "DECVALUE":監視対象インターフェースがダウンしたときのプライオリティの減少幅を指定

なお上の設定方法は、オブジェクトトラッキングと呼ばれる方法であり、オブジェクトトラッキングの対象としてインターフェースを設定していることになります。

設定例

作業環境

  • 型番:C891FJ-K9
  • バージョン:15.3(3)M5

検証構成

HSRP パラメータ

項目アクティブ機
(VLAN10)
スタンバイ機
(VLAN10)
アクティブ機
(VLAN20)
スタンバイ機
(VLAN20)
グループ番号10同左20同左
物理 IFGE0GE0GE1GE1
L3 IFVlan10Vlan10Vlan20Vlan20
実 IP10.0.10.25310.0.10.25210.0.20.25310.0.20.252
仮想 IP10.0.10.254同左10.0.20.254同左
Hello 間隔1同左1同左
ホールドタイム3同左3同左
プライオリティ200100200100
プリエンプト有効有効有効有効
IFトラッキング対象GE1なしGE0なし
トラック番号12
プライオリティ減少幅110110

HSRP 設定

■アクティブ機

track 1 interface GigabitEthernet0 line-protocol
track 2 interface GigabitEthernet1 line-protocol

interface GigabitEthernet0
 switchport access vlan 10
 no ip address

interface GigabitEthernet1
 switchport access vlan 20
 no ip address

interface Vlan10
 ip address 10.0.10.253 255.255.255.0
 standby 10 ip 10.0.10.254
 standby 10 timers 1 3
 standby 10 priority 200
 standby 10 preempt
 standby 10 track 2 decrement 110

interface Vlan20
 ip address 10.0.20.253 255.255.255.0
 standby 20 ip 10.0.20.254
 standby 20 timers 1 3
 standby 20 priority 200
 standby 20 preempt
 standby 20 track 1 decrement 110

■スタンバイ機

interface GigabitEthernet0
 switchport access vlan 10
 no ip address

interface GigabitEthernet1
 switchport access vlan 20
 no ip address

interface Vlan10
 ip address 10.0.10.252 255.255.255.0
 standby 10 ip 10.0.10.254
 standby 10 timers 1 3
 standby 10 preempt

interface Vlan20
 ip address 10.0.20.252 255.255.255.0
 standby 20 ip 10.0.20.254
 standby 20 timers 1 3
 standby 20 preempt

HSRP 状態確認コマンド

  • show standby brief
ACTIVE-RT#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl10        10   200 P Active  local           10.0.10.252     10.0.10.254
Vl20        20   200 P Active  local           10.0.20.252     10.0.20.254

STANDBY-RT#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl10        10   100 P Standby 10.0.10.253     local           10.0.10.254
Vl20        20   100 P Standby 10.0.20.253     local           10.0.20.254
  • show standby
ACTIVE-RT#show standby
Vlan10 - Group 10
  State is Active
    13 state changes, last state change 00:51:50
  Virtual IP address is 10.0.10.254
  Active virtual MAC address is 0000.0c07.ac0a
    Local virtual MAC address is 0000.0c07.ac0a (v1 default)
  Hello time 1 sec, hold time 3 sec
    Next hello sent in 0.896 secs
  Preemption enabled
  Active router is local
  Standby router is 10.0.10.252, priority 100 (expires in 3.312 sec)
  Priority 200 (configured 200)
    Track object 2 state Up decrement 110
  Group name is "hsrp-Vl10-10" (default)
Vlan20 - Group 20
  State is Active
    15 state changes, last state change 00:52:21
  Virtual IP address is 10.0.20.254
  Active virtual MAC address is 0000.0c07.ac14
    Local virtual MAC address is 0000.0c07.ac14 (v1 default)
  Hello time 1 sec, hold time 3 sec
    Next hello sent in 0.016 secs
  Preemption enabled
  Active router is local
  Standby router is 10.0.20.252, priority 100 (expires in 2.912 sec)
  Priority 200 (configured 200)
    Track object 1 state Up decrement 110
  Group name is "hsrp-Vl20-20" (default)
  • その他
ACTIVE-RT#show standby ?
  FastEthernet     FastEthernet IEEE 802.3
  GigabitEthernet  GigabitEthernet IEEE 802.3z
  Port-channel     Ethernet Channel of interfaces
  Vlan             Vlan IEEE 802.1q
  all              Include groups in disabled state
  brief            Brief output
  capability       HSRP capability
  delay            Group initialisation delay
  internal         Internal HSRP information
  neighbors        HSRP neighbors
  redirect         HSRP ICMP redirect information
  |                Output modifiers
  <cr>

動作確認

端末A から端末B へ連続 PING をしながらアクティブ機の VLAN10 側のインターフェースからケーブルを抜いてみます。なお端末のデフォルトゲートウェイは HSRP の VIP としています。

ケーブル抜線後、以下のように PING が NG となりますが数秒後に復旧します。ダウン時間が設定したホールドタイムと同程度の時間であることが分かります。

元々アクティブだった機器側では以下のようなログが記録され、トラッキングが動作していること、VLAN20 側の HSRP グループについてはスタンバイへ切り替わったことがわかります。

*Nov 12 07:59:52.243: %TRACK-6-STATE: 1 interface Gi0 line-protocol Up -> Down
*Nov 12 07:59:52.663: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Active -> Speak
*Nov 12 07:59:52.691: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0, changed state to down
*Nov 12 07:59:52.691: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to down
*Nov 12 07:59:52.691: %HSRP-5-STATECHANGE: Vlan10 Grp 10 state Active -> Init
*Nov 12 07:59:53.699: %LINK-3-UPDOWN: Interface GigabitEthernet0, changed state to down
*Nov 12 07:59:55.783: %HSRP-5-STATECHANGE: Vlan20 Grp 20 state Speak -> Standby

また、元々スタンバイだった機器側では以下コマンド結果より両 HSRP グループでアクティブに切り替わったことが分かります。

STANDBY-RT#show standby brief
                     P indicates configured to preempt.
                     |
Interface   Grp  Pri P State   Active          Standby         Virtual IP
Vl10        10   100 P Active  local           unknown         10.0.10.254
Vl20        20   100 P Active  local           10.0.20.253     10.0.20.254

参考ページ

Cisco IOS XE Denali 16.3.x(Catalyst 3850 スイッチ)ソフトウェア コンフィギュレーション ガイド - 『Configuring HSRP』 [Cisco Catalyst 3850 シリーズ スイッチ]
Cisco IOS XE Denali 16.3.x(Catalyst 3850 スイッチ)ソフトウェア コンフィギュレーション ガイド-『Configuring HSRP』
HSRP - Ciscoコンフィグ設定(仮想IPアドレス、Priority、Preempt)
HSRP - Ciscoコンフィグ設定(仮想IPアドレス、Priority、Preempt)
HSRP - インターフェーストラッキングとオブジェクトトラッキングの設定
HSRP - インターフェーストラッキングとオブジェクトトラッキングの設定

―――――――――――――

タイトルとURLをコピーしました