【Cisco】PPPoE サーバ設定 (PPPoE クライアント: IX,Si-R)

ネットワーク

はじめに

  • Cisco ルータを PPPoE サーバとして設定します
  • PPPoE クライアントとしては以下 2 つの機器を使用します
    • NEX Univerge IX
    • Fujitsu Si-R

検証構成

  • PPPoE サーバ
    • C891FJ-K9
    • バージョン:15.3(3)M5
  • PPPoE クライアントA
    • NEC Univerge IX2106
    • バージョン:10.2.16
  • PPPoE クライアントB
    • Fujitsu Si-R G100
    • バージョン:02.54
  • 今回は PPPoE サーバからは IP アドレスの払い出しを行わないこととします
  • 各 PPPoE クライアントの PPPoE 用インターフェースには静的に IP アドレスを設定します

PPPoE サーバの設定(Cisco)

PPPoE 用ユーザの設定

今回の例では 2 つの PPPoE クライアントで共通のユーザを使用します。

username pppoe@example.com password 0 hogehoge

PPPoE 用 Loopback インターフェースの設定

PPPoE クライアントごとに Loopback インターフェースを作成します。

interface Loopback1
 ip address 100.110.120.1 255.255.255.255
!
interface Loopback2
 ip address 100.110.120.2 255.255.255.255

IP アドレスプールの設定

PPPoE クライアントに IP アドレスを払い出す場合は、払い出す IP アドレスとして設定します。

#単一 IP 指定の場合
ip local pool "プール名" "x.x.x.x"

#範囲指定の場合
ip local pool "プール名" "x.x.x.x y.y.y.y"

今回の例では設定しません。

Virtual-Template インターフェースの設定

PPPoE クライアントごとに Virtual-Template インターフェースを作成します。

interface Virtual-Template1
 mtu 1454
 ip unnumbered Loopback1
 no peer default ip address
 ppp authentication chap

interface Virtual-Template2
 mtu 1454
 ip unnumbered Loopback2
 no peer default ip address
 ppp authentication chap
  • mtu は NTT フレッツの mtu に合わせて 1454 にします
  • IP アドレス設定については unnumbered で Loopback インターフェースを指定します
  • 今回は PPPoE クライアントへの IP アドレスの払い出しを行わないため no peer default ip address を設定します
    • 払い出す場合は peer default ip address pool <プール名> と設定します
  • PPP 認証方式として chap を設定します

bba-group (Broad Band Access グループ) の設定

PPPoE クライアントごとに bba-group を作成します。

bba-group pppoe PPPOE-GROUP1
 virtual-template 1

bba-group pppoe PPPOE-GROUP2
 virtual-template 2
  • PPPOE-GROUP1、PPPOE-GROUP2 の 2 つのグループを作成しています
  • bba-group に対して virtual-template インターフェイスを紐づけています

物理インターフェースの設定

PPPoE クライアントと接続する物理インターフェースの設定です。

interface GigabitEthernet8
 no ip address
 duplex auto
 speed auto
 pppoe enable group PPPOE-GROUP1

interface FastEthernet0
 no ip address
 duplex auto
 speed auto
 pppoe enable group PPPOE-GROUP2
  • IP アドレスは設定しません
  • pppoe enable group <bba-group名> で bba-group を紐づけています

ルーティング設定

必要に応じてルーティングを設定します。

今回の例では以下のスタティックルートを設定します。

ip route 10.1.200.0 255.255.255.0 192.168.150.1
ip route 10.1.201.0 255.255.255.0 192.168.150.2

PPPoE クライアント設定

NEC Univerge IX

#PPPoE プロファイルの設定
ppp profile profile-1
  authentication myname pppoe@example.com
  authentication password pppoe@example.com hogehoge

#PPPoE インターフェース設定
interface GigaEthernet0.1
  encapsulation pppoe
  auto-connect
  ppp binding profile-1
  ip address 192.168.150.1/24
  ip mtu 1454
  no shutdown

#LAN 側インターフェース設定
interface GigaEthernet1.0
  ip address 10.1.200.1/24
  no shutdown

#ルーティング設定
ip route default GigaEthernet0.1

Fujitsu Si-R

#PPPoE インターフェース設定
ether 1 1 vlan untag 1
remote 0 name Internet
remote 0 mtu 1454
remote 0 ap 0 name PPPoE
remote 0 ap 0 datalink bind vlan 1
remote 0 ap 0 ppp auth send pppoe@example.com hogehoge
remote 0 ap 0 keep connect
remote 0 ppp ipcp vjcomp disable
remote 0 ip address local 192.168.150.2
remote 0 ip msschange 1414

#LAN 側インターフェース設定
ether 2 1 vlan untag 2
lan 1 ip address 10.1.201.1/24 3
lan 1 vlan 2

#ルーティング設定
remote 0 ip route 0 default 1 1 

状態確認

Cisco

Router#show ip route
#略
      10.0.0.0/24 is subnetted, 2 subnets
S        10.1.200.0 [1/0] via 192.168.150.1
S        10.1.201.0 [1/0] via 192.168.150.2
      100.0.0.0/32 is subnetted, 2 subnets
C        100.110.120.1 is directly connected, Loopback1
C        100.110.120.2 is directly connected, Loopback2
      192.168.150.0/32 is subnetted, 2 subnets
C        192.168.150.1 is directly connected, Virtual-Access1.2
C        192.168.150.2 is directly connected, Virtual-Access1.1
Router#show ip interface brief
#略
FastEthernet0              unassigned      YES unset  up                    up
#略
GigabitEthernet8           unassigned      YES unset  up                    up
Loopback1                  100.110.120.1   YES manual up                    up
Loopback2                  100.110.120.2   YES manual up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access1.1          100.110.120.2   YES unset  up                    up
Virtual-Access1.2          100.110.120.1   YES unset  up                    up
Virtual-Access2            unassigned      YES unset  down                  down
Virtual-Template1          100.110.120.1   YES unset  down                  down
Virtual-Template2          100.110.120.2   YES unset  down                  down
#略
Router#show ppp all
Interface/ID OPEN+ Nego* Fail-     Stage    Peer Address    Peer Name
------------ --------------------- -------- --------------- --------------------
Vi1.1        LCP+ CHAP+ IPCP+      LocalT   192.168.150.2   \
pppoe@example.com
Vi1.2        LCP+ CHAP+ IPCP+      LocalT   192.168.150.1   \
pppoe@example.com
Router#show ppp interface gigabitEthernet 8
Gi8 No PPP serial context
PPP Session Info
----------------
Interface        : Vi1.2
PPP ID           : 0x3700000E
Phase            : UP
Stage            : Local Termination
Peer Name        : pppoe@example.com
Peer Address     : 192.168.150.1
Control Protocols: LCP[Open] CHAP+ IPCP[Open]
Session ID       : 14
AAA Unique ID    : 27
SSS Manager ID   : 0x4900001D
SIP ID           : 0xA00001C
PPP_IN_USE       : 0x11

Vi1.2 LCP: [Open]
Our Negotiated Options
Vi1.2 LCP:    MRU 1454 (0x010405AE)
Vi1.2 LCP:    AuthProto CHAP (0x0305C22305)
Vi1.2 LCP:    MagicNumber 0x3E066FFE (0x05063E066FFE)
Peer's Negotiated Options                         '
Vi1.2 LCP:    MRU 1492 (0x010405D4)
Vi1.2 LCP:    MagicNumber 0x07F72D7C (0x050607F72D7C)

Vi1.2 IPCP: [Open]
Our Negotiated Options
Vi1.2 IPCP:    Address 100.110.120.1 (0x0306646E7801)
Peer's Negotiated Options                         '
Vi1.2 IPCP:    Address 192.168.150.1 (0x0306C0A89601)
Peer's Rejected options                         '
  PrimaryDNS
  SecondaryDNS

Router#show ppp interface fastEthernet 0
Fa0 No PPP serial context
PPP Session Info
----------------
Interface        : Vi1.1
PPP ID           : 0xF00000F
Phase            : UP
Stage            : Local Termination
Peer Name        : pppoe@example.com
Peer Address     : 192.168.150.2
Control Protocols: LCP[Open] CHAP+ IPCP[Open]
Session ID       : 15
AAA Unique ID    : 28
SSS Manager ID   : 0xB900001F
SIP ID           : 0x8400001E
PPP_IN_USE       : 0x11

Vi1.1 LCP: [Open]
Our Negotiated Options
Vi1.1 LCP:    MRU 1454 (0x010405AE)
Vi1.1 LCP:    AuthProto CHAP (0x0305C22305)
Vi1.1 LCP:    MagicNumber 0x3E0AB407 (0x05063E0AB407)
Peer's Negotiated Options                          '
Vi1.1 LCP:    MagicNumber 0x1531EDFE (0x05061531EDFE)

Vi1.1 IPCP: [Open]
Our Negotiated Options
Vi1.1 IPCP:    Address 100.110.120.2 (0x0306646E7802)
Peer's Negotiated Options                         '
Vi1.1 IPCP:    Address 192.168.150.2 (0x0306C0A89602)
Peer's Rejected options                         '
  PrimaryDNS
  SecondaryDNS

NEC IX

Router(config)# show ip route
#略
S*   0.0.0.0/0 [1/1] is directly connected, GigaEthernet0.1, 1:36:50
     10.0.0.0/8 is subnetted, 1 subnets
C      10.1.200.0/24 [0/0] is directly connected, GigaEthernet1.0, 1:58:54
     100.0.0.0/8 is subnetted, 1 subnets
C      100.110.120.1/32 [0/0] is directly connected, GigaEthernet0.1, 2:42:02
C    192.168.150.0/24 [0/0] is directly connected, GigaEthernet0.1, 2:42:02
Router(config)# show pppoe session
SID     Remote address      Local address       Interface
14      84:3d:c6:ee:1b:f7   f8:b7:97:2f:f4:75   GigaEthernet0.1
Router(config)# show pppoe status
Interface GigaEthernet0.1 is up
  Control status:
    State is established
    Previous state is PADS wait
    Time since change 2 hours, 42 minutes and 49 seconds
    Host unique tag: 01968198
    Connected access concentrator is Router
  Statistics:
    PADI: 2 outputs, 0 retries
    PADO: 2 inputs
    PADR: 2 outputs, 0 retries
    PADS: 2 inputs
    PADT: 0 inputs, 0 outputs, 0 timeouts
    0 input discards, 0 output discards

Fujitsu Si-R

Si-R G100(config)# show ip route
FP  Destination/Mask   Gateway         Distance UpTime    Interface
--- ------------------ --------------- -------- --------- ------------------
*S  0.0.0.0/0          rmt0                   1 02:40:02  rmt0
*C  10.1.201.0/24      10.1.201.1             0 03:11:32  lan1
*L  192.168.150.2/32   192.168.150.2          0 02:40:02  rmt0
Si-R G100(config)# show interface interface rmt0
rmt0           MTU 1454    <UP,POINTOPOINT,RUNNING,SIMPLEX,MULTICAST>
    Description:
    Type: pseudo P2P interface
    Status: up since Jan  1 11:03:37 1970
    IP address:
      192.168.150.2
Si-R G100# show access-point remote 0
remote 0 ap 0         : Internet.PPPoE
  status              : connected
    detail            : connected
    since             : Jan  1 11:03:37 1970
    communicated time : 0000.02:46:11
  speed               : 100000000 bps
    send traffic      : 82 byte/s
    receive traffic   : 82 byte/s
  type                : PPPoE
    IPCP              : opened
      local address   : 192.168.150.2
      DNS server      : 255.255.255.255 255.255.255.255
    IPV6CP            : closed

疎通確認

■ IX (192.168.150.1) → Si-R (192.168.150.2) への疎通確認

Router(config)# ping 192.168.150.2
PING 192.168.150.1 > 192.168.150.2 56 data bytes
64 bytes from 192.168.150.2: icmp_seq=0 ttl=254 time=0.642 ms
64 bytes from 192.168.150.2: icmp_seq=1 ttl=254 time=0.693 ms
64 bytes from 192.168.150.2: icmp_seq=2 ttl=254 time=0.702 ms
64 bytes from 192.168.150.2: icmp_seq=3 ttl=254 time=0.684 ms
64 bytes from 192.168.150.2: icmp_seq=4 ttl=254 time=0.691 ms

--- 192.168.150.2 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip (ms)  min/avg/max = 0.642/0.682/0.702

■ 端末B (10.1.201.2) → 端末A (10.1.200.2) への疎通確認

C:\WINDOWS\system32>ping -S 10.1.201.2 10.1.200.2

10.1.200.2 に ping を送信しています 10.1.201.2 から 32 バイトのデータ:
10.1.200.2 からの応答: バイト数 =32 時間 =1ms TTL=125
10.1.200.2 からの応答: バイト数 =32 時間 =1ms TTL=125
10.1.200.2 からの応答: バイト数 =32 時間 =1ms TTL=125
10.1.200.2 からの応答: バイト数 =32 時間 =1ms TTL=125

10.1.200.2 の ping 統計:
    パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
    最小 = 1ms、最大 = 1ms、平均 = 1ms

ルート確認

C:\WINDOWS\system32>tracert -d 10.1.200.2

10.1.200.2 へのルートをトレースしています。経由するホップ数は最大 30 です

  1    <1 ms    <1 ms    <1 ms  10.1.201.1
  2     1 ms    <1 ms    <1 ms  100.110.120.2
  3     1 ms     1 ms     1 ms  192.168.150.1
  4     2 ms     1 ms     1 ms  10.1.200.2

トレースを完了しました。

―――――――――――――

タイトルとURLをコピーしました