【Cisco】PPPoE サーバおよび PPPoE クライアント設定テンプレ

ネットワーク
スポンサーリンク

作業環境

  • Cisco C891FJ-K9
    • バージョン:15.3(3)M5

PPPoE サーバ

設定テンプレート

username "<ユーザ名>" password "<パスワード>"

interface Loopback0
 ip address "<アドレス>" "<サブネットマスク>"

ip local pool "<プール名>" "<アドレス>"

interface Virtual-Template1
 mtu 1454
 ip unnumbered Loopback0
 peer default ip address pool "<プール名>"
 ppp authentication chap

bba-group pppoe "<bba-group 名>"
 virtual-template 1

interface "<IF 名>"
 no ip address
 duplex auto
 speed auto
 pppoe enable group "<bba-group 名>"

#必要に応じてルーティング設定

確認コマンド

  • show pppoe session all
Router#show pppoe session all
Total PPPoE sessions 1


session id: 2
local MAC address: 843d.c6ee.1bf7, remote MAC address: a46c.2af0.ac1b
virtual access interface: Vi2.1, outgoing interface: Gi8
    94 packets sent, 93 received
    2647 bytes sent, 2624 received

  • show ppp all
Router#show ppp all
Interface/ID OPEN+ Nego* Fail-     Stage    Peer Address    Peer Name
------------ --------------------- -------- --------------- --------------------
Vi2.1        LCP+ CHAP+ IPCP+      LocalT   192.168.1.2     user01

  • show ip interface brief
Router#show ip interface brief
Interface                  IP-Address      OK? Method Status                Protocol
Async3                     unassigned      YES unset  down                  down
BRI0                       unassigned      YES unset  administratively down down
BRI0:1                     unassigned      YES unset  administratively down down
BRI0:2                     unassigned      YES unset  administratively down down
FastEthernet0              unassigned      YES unset  administratively down down
GigabitEthernet0           unassigned      YES unset  up                    up
GigabitEthernet1           unassigned      YES unset  down                  down
GigabitEthernet2           unassigned      YES unset  down                  down
GigabitEthernet3           unassigned      YES unset  down                  down
GigabitEthernet4           unassigned      YES unset  down                  down
GigabitEthernet5           unassigned      YES unset  down                  down
GigabitEthernet6           unassigned      YES unset  down                  down
GigabitEthernet7           unassigned      YES unset  down                  down
GigabitEthernet8           unassigned      YES unset  up                    up
Loopback0                  192.168.1.1     YES manual up                    up
Virtual-Access1            unassigned      YES unset  down                  down
Virtual-Access2            unassigned      YES unset  up                    up
Virtual-Access2.1          192.168.1.1     YES unset  up                    up
Virtual-Template1          192.168.1.1     YES unset  down                  down
Vlan1                      unassigned      YES unset  down                  down
Vlan10                     10.1.10.100     YES manual down                  down
Vlan11                     10.1.11.254     YES manual up                    up

  • show ip route
Router#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.1.11.0/24 is directly connected, Vlan11
L        10.1.11.254/32 is directly connected, Vlan11
      192.168.1.0/32 is subnetted, 2 subnets
C        192.168.1.1 is directly connected, Loopback0
C        192.168.1.2 is directly connected, Virtual-Access2.1

  • show ppp interface <対クライアント物理IF名>
Router#show ppp interface gigabitEthernet 8
Gi8 No PPP serial context
PPP Session Info
----------------
Interface        : Vi2.1
PPP ID           : 0x6B000002
Phase            : UP
Stage            : Local Termination
Peer Name        : user01
Peer Address     : 192.168.1.2
Control Protocols: LCP[Open] CHAP+ IPCP[Open]
Session ID       : 2
AAA Unique ID    : 31
SSS Manager ID   : 0x67000005
SIP ID           : 0xF6000004
PPP_IN_USE       : 0x11

Vi2.1 LCP: [Open]
Our Negotiated Options
Vi2.1 LCP:    MRU 1500 (0x010405DC)
Vi2.1 LCP:    AuthProto CHAP (0x0305C22305)
Vi2.1 LCP:    MagicNumber 0x3F0FE45E (0x05063F0FE45E)
Peer's Negotiated Options
Vi2.1 LCP:    MagicNumber 0x6C6387E0 (0x05066C6387E0)

Vi2.1 IPCP: [Open]
Our Negotiated Options
Vi2.1 IPCP:    Address 192.168.1.1 (0x0306C0A80101)
Peer's Negotiated Options
Vi2.1 IPCP:    Address 192.168.1.2 (0x0306C0A80102)

PPPoE クライアント

設定テンプレート

interface dialer "<番号a>"
 ip address negotiated
 ip mtu 1454
 encapsulation ppp
 dialer pool "<番号b>"
 dialer-group "<番号c>"
 ppp authentication chap callin
 ppp chap hostname "<ユーザ名>"
 ppp chap password "<パスワード>"

dialer-list "<番号c>" protocol ip permit

#WAN側インターフェース
interface "<IF 名>"
 pppoe-client dial-pool-number "<番号b>"

#LAN側インターフェース
interface "<IF 名>"
 ip tcp adjust-mss 1414

##以下、必要に応じて NAT 設定-------
interface dialer "<番号a>"
 ip nat outside

#LAN側インターフェース
interface "<IF 名>"
 ip nat inside

ip nat inside source list 1 interface dialer "<番号a>" overload
access-list 1 permit "<ネットワーク>" "<ワイルドカードマスク>"

##以下、必要に応じてルーティング設定-------
ip route 0.0.0.0 0.0.0.0 dialer "<番号a>"

確認コマンド

  • show pppoe session all
Router#show pppoe session all
Total PPPoE sessions 1


session id: 2
local MAC address: a46c.2af0.ac1b, remote MAC address: 843d.c6ee.1bf7
virtual access interface: Vi1, outgoing interface: Gi8
 VLAN Priority: 0
    199 packets sent, 0 received
    4104 bytes sent, 0 received

  • show ppp all
Router#show ppp all
Interface/ID OPEN+ Nego* Fail-     Stage    Peer Address    Peer Name
------------ --------------------- -------- --------------- --------------------
Vi1          LCP+ IPCP+ CDPCP-     LocalT   192.168.1.1     Router

  • show ip interface brief
Router#show ip interface brief
Any interface listed with OK? value "NO" does not have a valid configuration

Interface                  IP-Address      OK? Method Status                Protocol
Async3                     unassigned      YES unset  down                  down
BRI0                       unassigned      YES unset  administratively down down
BRI0:1                     unassigned      YES unset  administratively down down
BRI0:2                     unassigned      YES unset  administratively down down
Dialer1                    192.168.1.2     YES IPCP   up                    up
FastEthernet0              unassigned      YES unset  down                  down
GigabitEthernet0           unassigned      YES unset  down                  down
GigabitEthernet1           unassigned      YES unset  down                  down
GigabitEthernet2           unassigned      YES unset  down                  down
GigabitEthernet3           unassigned      YES unset  down                  down
GigabitEthernet4           unassigned      YES unset  down                  down
GigabitEthernet5           unassigned      YES unset  down                  down
GigabitEthernet6           unassigned      YES unset  down                  down
GigabitEthernet7           unassigned      YES unset  down                  down
GigabitEthernet8           unassigned      YES unset  up                    up
NVI0                       unassigned      NO  unset  up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Vlan1                      unassigned      YES unset  down                  down

  • show ip route
Router#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Dialer1
      192.168.1.0/32 is subnetted, 2 subnets
C        192.168.1.1 is directly connected, Dialer1
C        192.168.1.2 is directly connected, Dialer1

―――――――――――――

タイトルとURLをコピーしました