Cisco Packet Tracer でネットワーク構築実践 #1

ネットワーク

Cisco Packet Tracer(以下、Packet Tracer) を使用してお手軽にネットワーク構築経験を積んでしまおうというシリーズの第1回目です。

・Packet Tracer のインストール方法についてはこちら
・Packet Tracer の基本的な使い方はこちら

対象環境

  • Packet Tracer バージョン 7.3

構築するネットワーク

今回構築するネットワークの構成は以下の通りです。

使用する機能

  • 機器管理設定
    • ホスト名設定
    • ドメイン名設定
    • ユーザ設定
    • enable パスワード設定
    • コンソール接続パスワードの設定
    • SSH 接続設定
    • パスワード情報の暗号化
  • インターフェース設定
    • VLAN インターフェース作成
    • IP アドレス設定
  • VLAN 設定
    • VLAN ID 作成
    • アクセスポート設定
    • トランクポート設定
  • ルーティング設定
    • ルーティング有効化
    • OSPF 基本設定

ネットワーク構築

それでは早速ネットワーク構築をしていきます。最初から最終形を目指すのではなく、段階的に進めていきます。

まずは Packet Tracer を起動します。

機器の設置

まずは以下の 4 つの機器を設置します。

  • 3650-24PS(レイヤ3スイッチ)
  • 2960-24TT(レイヤ2スイッチ)
  • PC-PT 2台

■目指す構成

■Packet Tracer 画面

ケーブル接続

続いて機器同士をストレートケーブルで接続します。

接続先インターフェースは以下画像に記載の通りにします。

  • Gig は GigabitEthernet の略です
  • Fa は FastEthernet の略です

■目指す構成

■Packet Tracer 画面

機器管理設定

各スイッチの管理用の設定をしていきます。以下の通り設定します。

設定項目3650-24PS2960-24TT
ホスト名L3SW-01L2SW-01
ドメイン名test.comtest.com
ユーザ名adminadmin
ログインパスワードciscocisco
enable パスワードciscocisco
パスワード表示暗号化有効有効
コンソール接続パスワードciscocisco
SSH 接続設定SSH バージョン 2SSH バージョン 2

3650-24PS の設定

(1) 電源モジュール追加

3650-24PS についてはまず電源モジュールを追加する必要があるため、機器ウインドウの [Physical] タブで追加してください。手順詳細はこちら参照。

(2) CLI 表示

起動直後の CLI では最初に対話形式で設定するかを聞かれますが no と入力してプロンプトを表示させます。

Would you like to enter the initial configuration dialog? [yes/no]: no

Press RETURN to get started!

Switch>

(3) ホスト名設定

ホスト名は L3SW-01 と設定します。

Switch>enable
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname L3SW-01
L3SW-01(config)#

(4) ユーザ設定

ユーザについては以下の通り設定します。

  • ユーザ名:admin
  • ログインパスワード:cisco
L3SW-01(config)#username admin password cisco
L3SW-01(config)#

(5) enable パスワード設定

特権モードへ移行する際のパスワードを cisco と設定します。

L3SW-01(config)#enable password cisco
L3SW-01(config)#

(6) パスワード表示の暗号化設定

コンフィグを表示したときにパスワード部分を暗号化する設定を行います。

L3SW-01(config)#service password-encryption 
L3SW-01(config)#

(7) コンソール接続パスワードの設定

機器にコンソール接続した際のパスワードを cisco と設定します。

L3SW-01(config)#line console 0
L3SW-01(config-line)#password cisco
L3SW-01(config-line)#login
L3SW-01(config-line)#exit
L3SW-01(config)#

(8) SSH 接続用設定

他機器から SSH 接続して CLI にアクセスできるようにする設定を行います。

まず SSH バージョンを 2 と設定します。

L3SW-01(config)#ip ssh version 2
Please create RSA keys (of at least 768 bits size) to enable SSH v2.
L3SW-01(config)#

この後、SSH 用の RSA 鍵を作成しますが、その鍵を作成するためには先に機器のドメイン名を設定する必要があります。ドメイン名を設定せずに RSA 鍵を作成しようとすると以下のエラーになります。

L3SW-01(config)#crypto key generate rsa
% Please define a domain-name first.

ドメイン名を test.com と設定します。

L3SW-01(config)#ip domain-name test.com
L3SW-01(config)#

続いて RSA 鍵を生成します。途中で RSA 鍵の長さを聞かれますが 2048 と指定します。

L3SW-01(config)#crypto key generate rsa
The name for the keys will be: L3SW-01.test.com
Choose the size of the key modulus in the range of 360 to 2048 for your
  General Purpose Keys. Choosing a key modulus greater than 512 may take
  a few minutes.

How many bits in the modulus [512]: 2048
% Generating 2048 bit RSA keys, keys will be non-exportable...[OK]

L3SW-01(config)#

最後に SSH 用に VTY line(仮想端末ライン)を以下の通り設定します。

  • 対象ポート番号:0~15
  • 機器に設定されているユーザとパスワードでログインできるようにする
  • SSH 接続のみ受け付けるようにする
L3SW-01(config)#line vty 0 15
L3SW-01(config-line)#login
L3SW-01(config-line)#login loca
L3SW-01(config-line)#login local 
L3SW-01(config-line)#tra
L3SW-01(config-line)#transport inpu
L3SW-01(config-line)#transport input ssh
L3SW-01(config-line)#exit
L3SW-01(config)#

(9) コンフィグの確認

設定した内容がコンフィグに反映されていることを確認します。

L3SW-01(config)#exit
L3SW-01#show run
Building configuration...
.
.
.
service password-encryption
!
hostname L3SW-01
!
enable password 7 0822455D0A16
!
!
!
ip ssh version 2
ip domain-name test.com
!
username admin privilege 1 password 7 0822455D0A16
.
.
.
line con 0
 password 7 0822455D0A16
 login

line vty 0 4
 login local
 transport input ssh
line vty 5 15
 login local
 transport input ssh
.
.
.

(10) コンフィグの保存

コンフィグの確認ができたら write memory コマンドでコンフィグを保存します。

L3SW-01#write memory 
Building configuration...
[OK]
L3SW-01#

2960-24TT の設定

3650-24PS と同じように設定します。設定コマンドのみ以下に記載します。

hostname L2SW-01

username admin password cisco

enable password cisco

service password-encryption 

line con 0
 password cisco
 login
 exit
 
ip ssh version 2
ip domain-name test.com

crypto key generate rsa
####鍵長は 2048 と指定

line vty 0 15
 login local
 transport input ssh
 end

write memory

インターフェースおよび VLAN 設定

■目指す構成

3650-24PS の設定

3650-24PS については以下の通り設定します。

設定項目3650-24PS
VLAN ID 作成10,20
GigbitEthernet 1/0/24 の設定以下の通りトランクポート設定とする
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 10,20
Vlan10 の IP アドレス10.0.10.254 255.255.255.0
vlan20 の IP アドレス10.0.20.254 255.255.255.0
IP ルーティングの有効化有効

(1) VLAN ID の作成

VLAN ID として 10 と 20 を作成します。

L3SW-01(config)#vlan 10
L3SW-01(config-vlan)#exit
L3SW-01(config)#vlan 20
L3SW-01(config-vlan)#exit
L3SW-01(config)#

VLAN データベースを確認し、VLAN 10,20 が作成されていることを確認します。

L3SW-01(config)#do show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
.
.
.
10   VLAN0010                         active    
20   VLAN0020                         active    
.
.
.
VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
.
.
.
L3SW-01(config)#

(2) GigbitEthernet 1/0/24 の設定

GigbitEthernet 1/0/24 については以下の通り設定します。

  • トランキングプロトコルとして IEEE802.1Q を使用
  • スイッチポートモードをトランクとする
  • 通信許可する VLAN ID を 10 と 20 のみと設定する
L3SW-01(config)#interface gigabitEthernet 1/0/24
L3SW-01(config-if)#switchport trunk encapsulation dot1q
L3SW-01(config-if)#switchport mode trunk
L3SW-01(config-if)#switchport trunk allowed vlan 10,20
L3SW-01(config-if)#exit
L3SW-01(config)#

(3) VLAN インターフェースの作成および設定

VLAN ID 10,20 に対応する論理的な VLAN インターフェースを作成して設定します。

作成する VLAN インターフェースは以下の 2 つです。

  • Vlan10
    • IP アドレス:10.0.10.254 255.255.255.0
  • Vlan20
    • IP アドレス:10.0.20.254 255.255.255.0
L3SW-01(config)#interface Vlan10
L3SW-01(config-if)#ip address 10.0.10.254 255.255.255.0
L3SW-01(config-if)#exit
L3SW-01(config)#interface Vlan20
L3SW-01(config-if)#ip address 10.0.20.254 255.255.255.0
L3SW-01(config-if)#exit
L3SW-01(config)#

(4) IP ルーティングの有効化設定

IP ルーティングがデフォルトで無効となっているため、有効化します。

L3SW-01(config)#ip routing
L3SW-01(config)#

(5) コンフィグの確認

設定した内容がコンフィグに反映されていることを確認します。

L3SW-01(config)#exit
L3SW-01#show run
Building configuration...
.
.
.
ip routing
.
.
.
interface GigabitEthernet1/0/24
 switchport trunk allowed vlan 10,20
 switchport trunk encapsulation dot1q
 switchport mode trunk
.
.
.
interface Vlan10
 mac-address 00d0.bad8.5901
 ip address 10.0.10.254 255.255.255.0
!
interface Vlan20
 mac-address 00d0.bad8.5902
 ip address 10.0.20.254 255.255.255.0
.
.
.

※VLAN インターフェースの mac-address 設定は自動で入ります

(6) コンフィグの保存

コンフィグの確認ができたら write memory コマンドでコンフィグを保存します。

L3SW-01#write memory 
Building configuration...
[OK]
L3SW-01#

2960-24TT の設定

2960-24TT については以下の通り設定します。

設定項目2960-24TT
VLAN ID 作成10,20
FastEthernet 0/1 の設定以下の通りアクセスポート設定とする
switchport mode access
switchport access vlan 10
FastEthernet 0/2 の設定以下の通りアクセスポート設定とする
switchport mode access
switchport access vlan 20
FastEthernet 0/24 の設定以下の通りトランクポート設定とする
switchport mode trunk
switchport trunk allowed vlan 10,20
Vlan10 の IP アドレス10.0.10.100 255.255.255.0
vlan20 の IP アドレス10.0.20.100 255.255.255.0

トランクポートの設定について、2960-24TT ではトランキングプロトコルの設定は不要です。(仕様上設定ができません。)

3650-24PS と同じように設定します。設定コマンドのみ以下に記載します。

vlan 10
 exit
vlan 20
 exit

interface FastEthernet0/1
 switchport mode access
 switchport access vlan 10
 exit

interface FastEthernet0/2
 switchport mode access
 switchport access vlan 20
 exit

interface FastEthernet0/24
 switchport mode trunk
 switchport trunk allowed vlan 10,20
 exit

interface Vlan10
 ip address 10.0.10.100 255.255.255.0
 exit

interface Vlan20
 ip address 10.0.20.100 255.255.255.0
 exit

end
write memory

PC のネットワーク設定

PC0 と PC1 については以下の通り設定します。

設定項目PC0PC1
IP アドレス10.0.10.110.0.20.1
サブネットマスク255.255.255.0255.255.255.0
デフォルトゲートウェイ10.0.10.25410.0.20.254

■PC0 の設定

■PC1 の設定

ここまでの動作確認

PC からの Ping 疎通確認

PC0 でコマンドプロンプトを起動します。

以下の各 IP と疎通が取れることを確認します。

  • 10.0.10.100(L2SW-01 の Vlan 10 の IPアドレス)
  • 10.0.10.254(L3SW-01 の Vlan 10 の IPアドレス)
  • 10.0.20.1(PC1 の IPアドレス)
  • 10.0.20.100(L2SW-01 の Vlan 20 の IPアドレス)
  • 10.0.20.254(L3SW-01 の Vlan 20 の IPアドレス)
C:\>ping 10.0.10.100

Pinging 10.0.10.100 with 32 bytes of data:

Reply from 10.0.10.100: bytes=32 time<1ms TTL=255
Reply from 10.0.10.100: bytes=32 time<1ms TTL=255
Reply from 10.0.10.100: bytes=32 time<1ms TTL=255
Reply from 10.0.10.100: bytes=32 time<1ms TTL=255

Ping statistics for 10.0.10.100:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\>ping 10.0.10.254

Pinging 10.0.10.254 with 32 bytes of data:

Reply from 10.0.10.254: bytes=32 time=1ms TTL=255
Reply from 10.0.10.254: bytes=32 time<1ms TTL=255
Reply from 10.0.10.254: bytes=32 time<1ms TTL=255
Reply from 10.0.10.254: bytes=32 time<1ms TTL=255

Ping statistics for 10.0.10.254:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms

C:\>ping 10.0.20.1

Pinging 10.0.20.1 with 32 bytes of data:

Reply from 10.0.20.1: bytes=32 time<1ms TTL=127
Reply from 10.0.20.1: bytes=32 time<1ms TTL=127
Reply from 10.0.20.1: bytes=32 time<1ms TTL=127
Reply from 10.0.20.1: bytes=32 time<1ms TTL=127

Ping statistics for 10.0.20.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\>ping 10.0.20.100

Pinging 10.0.20.100 with 32 bytes of data:

Reply from 10.0.20.100: bytes=32 time<1ms TTL=255
Reply from 10.0.20.100: bytes=32 time=1ms TTL=255
Reply from 10.0.20.100: bytes=32 time<1ms TTL=255
Reply from 10.0.20.100: bytes=32 time<1ms TTL=255

Ping statistics for 10.0.20.100:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms

C:\>ping 10.0.20.254

Pinging 10.0.20.254 with 32 bytes of data:

Reply from 10.0.20.254: bytes=32 time<1ms TTL=255
Reply from 10.0.20.254: bytes=32 time=1ms TTL=255
Reply from 10.0.20.254: bytes=32 time<1ms TTL=255
Reply from 10.0.20.254: bytes=32 time<1ms TTL=255

Ping statistics for 10.0.20.254:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms

C:\>

PC から各スイッチへの SSH 接続確認

PC0 で SSH クライアントを起動します。

(1) L3SW-01 への SSH 接続

以下画像(左)の通り入力し [Connect] をクリックします。以下画像(右)の画面が表示されたらログインパスワードを入力し、ログインできることを確認します。

(2) L2SW-01 への SSH 接続

以下画像(左)の通り入力し [Connect] をクリックします。以下画像(右)の画面が表示されたらログインパスワードを入力し、ログインできることを確認します。

機器追加(1)

次に機器を追加します。以下画像の右半分を追加します。

右半分の構成は左半分と全く同じで、設定パラメータが異なるだけです。

■目指す構成

■Packet Tracer 画面

L3SW-02(3650-24PS)の設定

L3SW-01 と同じように設定します。設定コマンドのみ以下に記載します。

hostname L3SW-02
username admin password cisco
enable password cisco
service password-encryption

line con 0
 password cisco
 login
 exit

ip ssh version 2
ip domain-name test.com
crypto key generate rsa
####鍵長は 2048 と指定する

line vty 0 15
 login local
 transport input ssh
 exit

vlan 110
 exit
vlan 120
 exit

interface GigabitEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 110,120
 switchport mode trunk
 exit

interface Vlan110
 ip address 10.1.10.254 255.255.255.0
 exit

interface Vlan120
 ip address 10.1.20.254 255.255.255.0
 exit

ip routing

end
write memory

L2SW-02(2960-24TT)の設定

L2SW-01 と同じように設定します。設定コマンドのみ以下に記載します。

hostname L2SW-02
username admin password cisco
enable password cisco
service password-encryption

line con 0
 password cisco
 login
 exit

ip ssh version 2
ip domain-name test.com
crypto key generate rsa
####鍵長は 2048 と指定する

line vty 0 15
 login local
 transport input ssh
 exit

vlan 110
 exit
vlan 120
 exit

interface FastEthernet0/1
 switchport mode access
 switchport access vlan 110
 exit

interface FastEthernet0/2
 switchport mode access
 switchport access vlan 120
 exit

interface FastEthernet0/24
 switchport trunk allowed vlan 110,120
 switchport mode trunk
 exit

interface Vlan110
 ip address 10.1.10.100 255.255.255.0
 exit

interface Vlan120
 ip address 10.1.20.100 255.255.255.0
 exit

end
write memory

PC2 と PC3 の設定

PC2 と PC3 については以下の通り設定します。

設定項目PC2PC3
IP アドレス10.1.10.110.1.20.1
サブネットマスク255.255.255.0255.255.255.0
デフォルトゲートウェイ10.1.10.25410.1.20.254

■PC2 の設定

■PC3 の設定

動作確認

(L3SW-02、L2SW-02) 側のネットワークについても、(L3SW-01、L2SW-01) 側と同様に、PC から各 IP への Ping 疎通確認と各スイッチへの SSH 接続確認を行います。

機器追加(2)

次のステップとしては、以下画像のようにルータ ISR4321 を一台追加して、L3SW-01 と L3SW-02 間を接続します。

■目指す構成

■Packet Tracer 画面

ルータ設定および追加セグメントのインターフェース設定

追加したルータの設定および、L3SW-01/02 の Gig1/0/1 の IP アドレス設定を行います。

■目指す構成

ルータの設定

ルータについては以下の通り設定します。

設定項目RT-01
ホスト名RT-01
ドメイン名test.com
ユーザ名admin
ログインパスワードcisco
enable パスワードcisco
パスワード表示暗号化有効
コンソール接続パスワードcisco
SSH 接続設定SSH バージョン 2
GigabitEthernet 0/0/0 の
IP アドレス
172.16.0.1 255.255.255.252
GigabitEthernet 0/0/1 の
IP アドレス
172.16.1.1 255.255.255.252

設定コマンドを以下に記載します。注意としてインターフェースがデフォルトで shutdown (無効化)されているため、インターフェースに対して no shutdown コマンドを実行して有効化します。

hostname RT-01
username admin password cisco
enable password cisco
service password-encryption

line con 0
 password cisco
 login
 exit

ip ssh version 2
ip domain-name test.com
crypto key generate rsa
####鍵長は 2048 と指定する

line vty 0 15
 login local
 transport input ssh
 exit

interface GigabitEthernet0/0/0
 ip address 172.16.0.1 255.255.255.252
 no shutdown
 exit

interface GigabitEthernet0/0/1
 ip address 172.16.1.1 255.255.255.252
 no shutdown
 exit

end
write memory

L3SW-01/02 の設定

インターフェース GigabitEthernet1/0/1 を以下の通り設定します。

設定項目L3SW-01L3SW-02
L3 ポートとして設定有効 (no switchport)有効 (no switchport)
IP アドレス172.16.0.2 255.255.255.252172.16.1.2 255.255.255.252

■L3SW-01 の設定コマンド

interface GigabitEthernet1/0/1
 no switchport
 ip address 172.16.0.2 255.255.255.252
 duplex auto
 speed auto

end
write memory

■L3SW-02 の設定コマンド

interface GigabitEthernet1/0/1
 no switchport
 ip address 172.16.1.2 255.255.255.252
 duplex auto
 speed auto

end
write memory

ルータから疎通確認

ルータから L3SW-01/02 へ Ping 疎通が取れることを確認します。

RT-01#ping 172.16.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms

RT-01#ping 172.16.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

RT-01#

ルーティング(OSPF)設定

最後のステップとして、RT-01、L3SW-01/02 との間で動的ルーティングである OSPF を動作させて、PC0/PC1 側のセグメントと PC2/PC3 側のセグメント間で通信ができるようにします。

■目指す構成

■Packet Tracer 画面

OSPF の設計

項目RT-01L3SW-01L3SW-02備考
プロセス ID111
OSPF
インターフェース
Gig0/0/0
Gig0/0/1
Gig1/0/1
Vlan10
Vlna20
Gig1/0/1
Vlan110
Vlna120
設定項目 network で
このインターフェースを含む
ネットワークを設定する
エリアGig0/0/0 → 0
Gig0/0/1→ 1
すべて 0すべて 1
パッシブ
インターフェース
なしVlan10
Vlan20
Vlan110
Vlan120
パッシブインターフェースに設定すると
OSPF Hello パケットを送信しない

RT-01 の OSPF 設定

router ospf 1
 network 172.16.0.0 0.0.0.3 area 0
 network 172.16.1.0 0.0.0.3 area 1

end
write memory

L3SW-01 の OSPF 設定

router ospf 1
 passive-interface Vlan10
 passive-interface Vlan20
 network 172.16.0.0 0.0.0.3 area 0
 network 10.0.10.0 0.0.0.255 area 0
 network 10.0.20.0 0.0.0.255 area 0

end
write memory

L3SW-02 の OSPF 設定

router ospf 1
 passive-interface Vlan110
 passive-interface Vlan120
 network 172.16.1.0 0.0.0.3 area 1
 network 10.1.10.0 0.0.0.255 area 1
 network 10.1.20.0 0.0.0.255 area 1

end
write memory

OSPF 状態確認

■RT-01

OSPFネイバー確認

RT-01#show ip ospf neighbor 


Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.0.2        1   FULL/BDR        00:00:31    172.16.0.2      GigabitEthernet0/0/0
172.16.1.2        1   FULL/DR         00:00:31    172.16.1.2      GigabitEthernet0/0/1

OSPFルート確認

RT-01#show ip route ospf
     10.0.0.0/24 is subnetted, 4 subnets
O       10.0.10.0 [110/2] via 172.16.0.2, 00:22:33, GigabitEthernet0/0/0
O       10.0.20.0 [110/2] via 172.16.0.2, 00:22:33, GigabitEthernet0/0/0
O       10.1.10.0 [110/2] via 172.16.1.2, 00:09:57, GigabitEthernet0/0/1
O       10.1.20.0 [110/2] via 172.16.1.2, 00:09:57, GigabitEthernet0/0/1

■L3SW-01

OSPFネイバー確認

L3SW-01#show ip ospf neighbor 


Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.1.1        1   FULL/DR         00:00:31    172.16.0.1      GigabitEthernet1/0/1

OSPFルート確認

L3SW-01#show ip route ospf
     10.0.0.0/24 is subnetted, 4 subnets
O IA    10.1.10.0 [110/3] via 172.16.0.1, 00:11:12, GigabitEthernet1/0/1
O IA    10.1.20.0 [110/3] via 172.16.0.1, 00:11:12, GigabitEthernet1/0/1
     172.16.0.0/30 is subnetted, 2 subnets
O IA    172.16.1.0 [110/2] via 172.16.0.1, 00:23:42, GigabitEthernet1/0/1

■L3SW-02

OSPFネイバー確認

L3SW-02#show ip ospf neighbor 


Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.1.1        1   FULL/BDR        00:00:35    172.16.1.1      GigabitEthernet1/0/1

OSPFルート確認

L3SW-02#show ip route ospf
     10.0.0.0/24 is subnetted, 4 subnets
O IA    10.0.10.0 [110/3] via 172.16.1.1, 00:24:38, GigabitEthernet1/0/1
O IA    10.0.20.0 [110/3] via 172.16.1.1, 00:24:38, GigabitEthernet1/0/1
     172.16.0.0/30 is subnetted, 2 subnets
O IA    172.16.0.0 [110/2] via 172.16.1.1, 00:24:38, GigabitEthernet1/0/1

最終確認

■最終構成

最終確認として PC0 から PC1、PC2、PC3 へ Ping 疎通が取れることを確認します。

終わりに

今回は以下の様な機能を使用してネットワークを構築しました。

  • 機器管理設定
    • ホスト名設定
    • ドメイン名設定
    • ユーザ設定
    • enable パスワード設定
    • コンソール接続パスワードの設定
    • SSH 接続設定
    • パスワード情報の暗号化
  • インターフェース設定
    • VLAN インターフェース作成
    • IP アドレス設定
  • VLAN 設定
    • VLAN ID 作成
    • アクセスポート設定
    • トランクポート設定
  • ルーティング設定
    • ルーティング有効化
    • OSPF 基本設定

各設定について細かい説明は記載しませんでしたが、気になった点は検索したりして調べてみてください。またパラメータやネットワーク構成を自分なりに変えてみて動作確認してみるとより理解が深まると思います。

―――――――――――――

タイトルとURLをコピーしました