【Cisco】VRF 環境での NTP サーバ設定について検証する

ネットワーク

はじめに

Cisco 機器で VRF を構築している環境においては、同期元 NTP サーバを VRF 別に設定することができます。2 つの VRF それぞれで異なる NTP サーバを設定し、かつ片方に prefer 指定をした場合、システム全体では各 VRF で設定した NTP サーバがプライマリ/セカンダリとして構成されるのかを検証します。

検証内容

作業環境

  • 型番:C891FJ-K9
  • バージョン:15.3(3)M5

検証構成

設定内容

C891FJ の設定は以下の通りにします。(関係箇所抜粋)

ip vrf VRF1
 rd 1:100

ip vrf VRF2
 rd 1:200

interface FastEthernet0
 ip vrf forwarding VRF2
 ip address 10.20.2.1 255.255.255.0
 duplex auto
 speed auto

interface GigabitEthernet8
 ip vrf forwarding VRF1
 ip address 10.20.1.1 255.255.255.0
 duplex auto
 speed auto

ip route vrf VRF1 0.0.0.0 0.0.0.0 10.20.1.254
ip route vrf VRF2 0.0.0.0 0.0.0.0 10.20.2.254

ntp server vrf VRF1 133.243.238.244 prefer
ntp server vrf VRF2 162.159.200.1

以下の部分で VRF1 で設定した NTP サーバに対して prefer 指定をしています。

ntp server vrf VRF1 133.243.238.244 prefer
ntp server vrf VRF2 162.159.200.1

ちなみに ntp source については VRF を指定して設定することはできません。

NTP 状態確認

RT#show ntp associations

  address         ref clock       st   when   poll reach  delay  offset   disp
+~162.159.200.1   10.51.8.120      3     92    128    17 42.826   1.116  0.805
*~133.243.238.244 .NICT.           1     28    128    37 49.752   5.446  0.961
 * sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured

RT#show ntp status
Clock is synchronized, stratum 2, reference is 133.243.238.244
nominal freq is 250.0000 Hz, actual freq is 250.0000 Hz, precision is 2**20
ntp uptime is 69100 (1/100 of seconds), resolution is 4000
reference time is E362E6B8.A4BE523D (10:07:04.643 JST Sat Nov 21 2020)
clock offset is 5.4462 msec, root delay is 49.75 msec
root dispersion is 13.20 msec, peer dispersion is 0.96 msec
loopfilter state is 'CTRL' (Normal Controlled Loop), drift is 0.000000038 s/s
system poll interval is 128, last update was 107 sec ago.

VRF1 で prefer 指定をして設定した NTP サーバと同期が行われていることが分かります。

prefer 指定を入れ替えてみる

以下のように prefer 指定を VRF2 側の NTP サーバにするよう設定変更してみます。

ntp server vrf VRF1 133.243.238.244
ntp server vrf VRF2 162.159.200.1 prefer

NTP 状態確認

RT#show ntp associations

  address         ref clock       st   when   poll reach  delay  offset   disp
*~162.159.200.1   10.51.8.120      3    127    128    17 38.972   0.336  0.513
+~133.243.238.244 .NICT.           1     62    128    37 58.305  17.049  1.203
 * sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured

RT#show ntp status
Clock is synchronized, stratum 4, reference is 162.159.200.1
nominal freq is 250.0000 Hz, actual freq is 249.9999 Hz, precision is 2**20
ntp uptime is 108500 (1/100 of seconds), resolution is 4016
reference time is E362E819.A6AA69FE (10:12:57.651 JST Sat Nov 21 2020)
clock offset is 0.3367 msec, root delay is 151.30 msec
root dispersion is 14.83 msec, peer dispersion is 1.41 msec
loopfilter state is 'CTRL' (Normal Controlled Loop), drift is 0.000000191 s/s
system poll interval is 128, last update was 148 sec ago.

VRF2で prefer 指定をして設定した NTP サーバと同期が行われていることが分かります。

まとめ

  • VRF 指定して NTP サーバを設定した場合、設定した NTP サーバはシステム全体の NTP サーバとしてリストに掲載される
  • VRF 指定して NTP サーバを設定した場合で、かつ prefer 指定したサーバとそうでないサーバある場合、システム全体としては prefer 指定したサーバが優先される(プライマリ/セカンダリ構成になる)

―――――――――――――

タイトルとURLをコピーしました