【Huawei AR ルータ】スイッチポートでの VLAN 設定方法

ルータ

検証環境

  • NetEngine AR651W
    • Version: V300R022C00SPC100

AR ルータのスイッチポート

AR651W ルータでは GE0~GE7 の 8 ポートをスイッチポートとして動作させることができます。
※レイヤ3インターフェースとして動作するよう設定することも可能です

以下ではこのスイッチポートの VLAN 設定について記載します。

VLAN ID の作成

まずは以下コマンドで使用する VLAN ID を作成しておきます。

VLAN ID の作成
  • vlan batch <vlan id>

実行例:

[Huawei]vlan batch 10
Info: This operation may take a few seconds. Please wait for a moment...done.
[Huawei]

スイッチポートの VLAN 設定

ポートリンクタイプ

AR ルータでは以下の 3 つのポートリンクタイプがあります。

ポートリンクタイプ
  • Access
    • タグ無しフレームの送受信が可能
  • Trunk
    • 複数の VLAN のタグ付きフレームと、1 つの VLAN のみのタグ無しフレームの送受信が可能
  • Hybrid
    • Trunk に似ているが少し違う(ここでは詳細は省略)

ポートリンクタイプは以下コマンドで設定します。

ポートリンクタイプの設定
  • port link-type <access|hybrid|trunk>

設定例:

[Huawei]interface GigabitEthernet 0/0/7
[Huawei-GigabitEthernet0/0/7]port link-type access
[Huawei-GigabitEthernet0/0/7]

アクセスポートの設定

スイッチポートをアクセスポートとして設定する場合は、ポートリンクタイプaccess と設定した上でどの VLAN ID を通すかを示すデフォルト VLAN の設定を行います。

デフォルト VLAN の設定

アクセスポートの所属する VLAN ID を指定する設定がデフォルト VLAN です。

デフォルト VLAN は以下コマンドで設定します。

デフォルト VLAN の設定
  • port default vlan <vlan-id>

デフォルト VLAN のデフォルト値は 1 です。

アクセスポートの設定例

以下では Gi0/0/7 をアクセスポートに設定し、デフォルト VLAN を 10 と設定しています。

[Huawei]interface GigabitEthernet 0/0/7
[Huawei-GigabitEthernet0/0/7]port link-type access
[Huawei-GigabitEthernet0/0/7]port default vlan 10
[Huawei-GigabitEthernet0/0/7]

トランクポートの設定

スイッチポートをトランクポートとして設定する場合は、ポートリンクタイプtrunk と設定した上でどの VLAN ID を通すかを示す allow-pass vlan の設定を行い、さらに必要に応じてトランクポートのデフォルト VLAN に当たる pvid vlan の設定を行います。

allow-pass vlan の設定

トランクポートではどの VLAN ID のタグについて送受信を許可するかを設定する必要があり、以下コマンドで設定します。

allow-pass vlan の設定
  • port trunk allow-pass vlan <vlan-id>
    • <vlan-id> の指定方法は以下が可能
      • 10 → 一つの ID を指定
      • 10 to 20 → 連続した範囲での指定
      • 5 10 15 → 複数の ID の指定
      • 10 to 20 25 →連続した値と複数 ID の指定の組み合わせ
      • all → すべての ID を許可

port trunk allow-pass vlan コマンドを複数回実行した場合、設定は上書きではなく、指定した VLAN ID が既存の port trunk allow-pass vlan 設定に追加されていく形になります。

allow-pass vlan のデフォルト値は VLAN ID 1 のみ許可です。

(オプション) pvid vlan の設定

トランクポートにおけるタグ無しフレームの VLAN ID を指定する設定が pvid vlan です。

pvid vlan は以下コマンドで設定します。

allow-pass vlan の設定
  • port trunk pvid vlan <vlan-id>

pvid vlan のデフォルト値は 1 です。

トランクポートの設定例

以下では Gi0/0/6 をトランクポートに設定し、allow-pass vlan を 10 と設定して VLAN ID 10 のタグが付いたフレームを許可しています。

[Huawei]interface GigabitEthernet0/0/6
[Huawei-GigabitEthernet0/0/6] port link-type trunk
[Huawei-GigabitEthernet0/0/6] port trunk allow-pass vlan 10
[Huawei-GigabitEthernet0/0/6]

VLAN インターフェースを使用した VLAN 間ルーティング

AR ルータでも Cisco の L3SW のように VLAN インターフェースを使用して VLAN 間ルーティングをすることができます。

設定としては VLAN インターフェースを作成して、その VLAN インターフェースに IP アドレスを設定します。

VLAN インターフェースの作成
  • interface Vlanif<vlan-id>

インターフェースに IP アドレスを設定するコマンドは以下です。

インターフェースの IP アドレスの設定
  • ip address <address> <mask>

設定例:

[Huawei]interface Vlanif10
[Huawei-Vlanif10]ip address 192.168.1.1 255.255.255.0
[Huawei-Vlanif10]

VLAN 関係の確認コマンド

  • display vlan
    • 作成されている VLAN ID 一覧を表示
[Huawei]display vlan
* : management-vlan
---------------------
The total number of vlans is : 2
VLAN ID Type         Status   MAC Learning Broadcast/Multicast/Unicast Property
--------------------------------------------------------------------------------
1       common       enable   enable       forward   forward   forward default
10      common       enable   enable       forward   forward   forward default

  • display vlan brief
    • 作成されている VLAN ID と所属ポート一覧を表示
[Huawei]display vlan brief
U:Up;D:Down;TG:Tagged;UT:Untagged;

VID  Name             Status  Ports
--------------------------------------------------------------------------------
1                     enable  UT: GE0/0/0(U) GE0/0/1(D) GE0/0/2(D) GE0/0/3(D)
                                  GE0/0/4(D) GE0/0/5(D) GE0/0/6(D)
                              TG: Wlan-Bss7(U)
10                    enable  UT: GE0/0/7(U)
                              TG: GE0/0/6(D)

参考資料

https://support.huawei.com/enterprise/en/doc/EDOC1100271714/10db067f/vlan-configuration


タイトルとURLをコピーしました