NEC IX ルータで Vlan 内スイッチングおよび Vlan 間ルーティングをするための設定方法

ネットワーク

作業環境

  • 型番:UNIVERGE IX2106
  • バージョン:10.2.16

はじめに

NEC IX について以下のような要件があったとします。

  • 複数のポートを Vlan A を通す tag または untag ポートとしたい
  • Vlan A について、IX をゲートウェイとして他 Vlan へルーティングさせたい

この場合、少し困ることになるかもしれません。というのも、例えば IX で Vlan A を通す tag または untag ポートを作成して他 Vlan へルーティングさせるためには、tag または untag ポートにしたいインターフェースに対して以下の設定が必要になります。

  • 対象インターフェースに対してサブインターフェースを作成する
  • 作成したサブインターフェースに対して Vlan A の IP アドレスを設定する

この方法だとサブインターフェース毎に IP アドレスを設定する必要がありますが、複数のインターフェースに対して同じ IP アドレスを設定することはできません。

このため、Vlan 間ルーティングをおこないつつ、複数インターフェースでの Vlan 内スイッチングを行うことは一見難しいように思えるかもしれません。

(SW-HUB インターフェースにて複数のポートを同じ Vlan グループに所属させることで似たようなことはできますが、tag ポートの混在や、他インターフェースを含めることはできません。)

ここで、IX にはこの問題を解決する機能があり、その機能とはブリッジ機能です。

以下ではこのブリッジ機能を使用した設定例を記載します。

Vlan 内スイッチングの設定例

複数インターフェースを使用した Vlan 内スイッチングの設定例を以下に記載します。なお、Vlan 間ルーティングは行わない場合の設定となっています。

複数 IF で Vlan 内スイッチングする場合(untag ポート)

通信要件

  • GigaEthernet0 と GigaEthernet1 を同じ Vlan の untag ポートとして使用できるようにし、Vlan 内でスイッチングできるようにする

設定例

まずブリッジ機能を有効化します。

bridge irb enable

次に各インターフェースを設定します。

interface GigaEthernet0.0
  no ip address
  bridge-group 1
  no shutdown

interface GigaEthernet1.0
  no ip address
  bridge-group 1
  no shutdown
  • スイッチングのみ行うため IP アドレスは設定しません
  • bridge-group <ID> でスイッチング対象インターフェースをグループ化しています
    • 同じ bridge-group ID を設定したインターフェース間でスイッチングが行われます

複数 IF で Vlan 内スイッチングする場合(tag ポート)

通信要件

  • GigaEthernet0 と GigaEthernet1 を tag ポートとして、同一 tag 内でスイッチングできるようにする
  • ポートに通す tag ID は 10,20,30 とする

設定例

まずブリッジ機能を有効化します。

bridge irb enable

次に各インターフェースを設定します。bridge-group ID は Vlan ID と同じ値にすることとします。

#GigaEthernet0 の設定
interface GigaEthernet0.0
  no ip address
  shutdown

interface GigaEthernet0.1
  encapsulation dot1q 10 tpid 8100
  no auto-connect
  no ip address
  bridge-group 10
  no shutdown

interface GigaEthernet0.2
  encapsulation dot1q 20 tpid 8100
  no auto-connect
  no ip address
  bridge-group 20
  no shutdown

interface GigaEthernet0.3
  encapsulation dot1q 30 tpid 8100
  no auto-connect
  no ip address
  bridge-group 30
  no shutdown

#GigaEthernet1 の設定
interface GigaEthernet1.0
  no ip address
  shutdown

interface GigaEthernet1.1
  encapsulation dot1q 10 tpid 8100
  no auto-connect
  no ip address
  bridge-group 10
  no shutdown

interface GigaEthernet1.2
  encapsulation dot1q 20 tpid 8100
  no auto-connect
  no ip address
  bridge-group 20
  no shutdown

interface GigaEthernet1.3
  encapsulation dot1q 30 tpid 8100
  no auto-connect
  no ip address
  bridge-group 30
  no shutdown

bridge-group ID は必ずしも Vlan ID と一致させる必要はなく、範囲内で任意の値を設定することができますが、Vlan ID と一致させるとわかりやすいのではないかと思います。

複数 IF で Vlan 内スイッチングする場合(tag,untag 混在)

通信要件

  • GigaEthernet0 は tag ポート (Vlan 10,20,30)、GigaEthernet1 は untag ポート (Vlan 10) として Vlan 10 内でスイッチングをできるようにする

設定例

まずブリッジ機能を有効化します。

bridge irb enable

次に各インターフェースを設定します。bridge-group ID は Vlan ID と同じ値にすることとします。GigaEthernet1 については untag ポートとするため GigaEthernet1.0 に設定します。

#GigaEthernet0 の設定
interface GigaEthernet0.0
  no ip address
  shutdown

interface GigaEthernet0.1
  encapsulation dot1q 10 tpid 8100
  no auto-connect
  no ip address
  bridge-group 10
  no shutdown

interface GigaEthernet0.2
  encapsulation dot1q 20 tpid 8100
  no auto-connect
  no ip address
  bridge-group 20
  no shutdown

interface GigaEthernet0.3
  encapsulation dot1q 30 tpid 8100
  no auto-connect
  no ip address
  bridge-group 30
  no shutdown

#GigaEthernet1 の設定
interface GigaEthernet1.0
  no ip address
  bridge-group 10
  no shutdown

Vlan 間ルーティングの設定例

複数インターフェースを使用して Vlan 内スイッチングと Vlan 間ルーティングの両方を行うための設定例を以下に記載します。

BVI インターフェースについて

ブリッジ機能を使用して Vlan 間ルーティングを行うためには BVI インターフェースを使用します。BVI インターフェースは仮想インターフェースであり、Vlan に対応する BVI インターフェースを作成して使用します。

こうすることで BVI インターフェースをゲートウェイとしてルーティングを行うことができます。

BVI インターフェースは Cisco 機器での SVI(インターフェース Vlan)と似たようなものです。

複数 IF を使用したVlan 間ルーティング設定例

通信要件

  • GigaEthernet0 および 1 を tag ポート (Vlan 10,20) として Vlan 内スイッチングおよび Vlan 間ルーティングをできるようにする

設定例

まずブリッジ機能を有効化します。

bridge irb enable

次にGigaEthernet0 および 1 の各インターフェースを設定します。bridge-group ID は Vlan ID と同じ値にすることとします。

#GigaEthernet0 の設定
interface GigaEthernet0.0
  no ip address
  shutdown

interface GigaEthernet0.1
  encapsulation dot1q 10 tpid 8100
  no auto-connect
  no ip address
  bridge-group 10
  no shutdown

interface GigaEthernet0.2
  encapsulation dot1q 20 tpid 8100
  no auto-connect
  no ip address
  bridge-group 20
  no shutdown

#GigaEthernet1 の設定
interface GigaEthernet1.0
  no ip address
  shutdown

interface GigaEthernet1.1
  encapsulation dot1q 10 tpid 8100
  no auto-connect
  no ip address
  bridge-group 10
  no shutdown

interface GigaEthernet1.2
  encapsulation dot1q 20 tpid 8100
  no auto-connect
  no ip address
  bridge-group 20
  no shutdown

最後にルーティングのゲートウェイとなる BVI インターフェースを設定します。

BVI インターフェース作成時のコマンド書式は以下の通りです。

  • interface BVI<ID>
    • <ID> 部分には 1-64 の中から任意の数値を指定します

BVI インターフェースに対しても bridge-group を設定できるため、対応付けたい Vlan ID に対して設定している bridge-group ID を設定します。また、ゲートウェイとなる IP アドレスを設定します。

interface BVI1
  ip address 10.0.10.254/24
  bridge-group 10
  no shutdown

interface BVI2
  ip address 10.0.20.254/24
  bridge-group 20
  no shutdown

その他の設定パターン

bridge-group 設定は、各種サブインターフェースに対して設定できるため、以下のような各種インターフェースを組み合わて同一 Vlan となるよう設定することができます。

  • untag 用サブインターフェース(サブインターフェース番号 0)
  • tag 用のサブインターフェース(サブインターフェース番号 1,2,…)
  • SW-HUB インターフェースの Vlan グループのサブインターフェース(untag、tag)

さらに BVI インターフェースを組み合わせることで Vlan 間ルーティングが可能になります。

―――――――――――――

タイトルとURLをコピーしました