【NEC UNIVERGE IX2106】インターフェース基本設定について

ネットワーク

作業環境

  • 型番:UNIVERGE IX2106
  • バージョン:10.2.16

物理と論理

物理インターフェースに対して論理的なインターフェースを作成することができます。

IX2106 では物理インターフェースとして GigaEthernet0(WAN接続用)と GigaEthernet1(LAN接続用、スイッチングハブ)がありますが、interface GigaEthernet0.x または interface GigaEthernet1.x (x:0~32) という論理的なインターフェースを作成することができます。

x が 0 のインターフェースを基本インターフェースx が 1~32 のインターフェースをサブインターフェースと呼んでいます。

サブインターフェースは、PPPoE やタグ VLAN を使用する際などに使用します。

インターフェースのコンフィグ構造

コンフィグ上では、物理インターフェースは device xxx と表記され、論理インターフェースは interface xxx と表記されます。

device "物理インターフェースA"
  #物理インターフェースAの設定項目1
  #物理インターフェースAの設定項目2
  #...

interface "論理インターフェースB"
  #論理インターフェースBの設定項目1
  #論理インターフェースBの設定項目2
  #...

コンフィグ例:

device GigaEthernet0
!
device GigaEthernet1
!
interface GigaEthernet0.0
  no ip address
  shutdown
!
interface GigaEthernet1.0
  ip address 192.168.1.254/24
  ip dhcp binding web-dhcp-gigaethernet1.0
  no shutdown
!
interface Loopback0.0
  no ip address
!
interface Null0.0
  no ip address
!

また IX2106 では GigaEthernet1 が 4 ポートあるスイッチングハブになっていて、そのスイッチングハブの各ポートについてのコンフィグは以下の様に device GigaEthernet1 配下に位置する構造になっています。

device GigaEthernet1
  port 1 duplex full
  port 2 speed 1000
  port 3 speed 100
  port 4 shutdown

停止(シャットダウン)と停止解除

  • shutdown
    • 設定対象:device、interface
    • 設定対象を停止する
  • no shutdown
    • 設定対象:device、interface
    • 設定対象の停止状態を解除する

設定例:

device GigaEthernet1
  shutdown

interface GigaEthernet1.0
  no shutdown

スイッチングハブの個別ポートについて設定する場合のコマンドは以下の様になります。

device GigaEthernet1
  port 1 shutdown

IP アドレスの設定

  • ip address ip/prefix
    • 設定対象:interface
    • IP アドレス設定の追加
    • ip:IP アドレス
    • prefix:プレフィックス値
  • no ip address [ip/prefix]
    • IP アドレス設定の削除

設定例:

interface GigaEthernet0.0
  ip address 192.168.2.100/24

Speed と Duplex の設定

  • speed speed
    • 設定対象:device
    • 設定対象の Speed を設定
    • speed 選択肢
      • 10:10Mbps
      • 100:100Mbps
      • 1000:1Gbps
      • 10000:10Gbps ※IX3315のみ
      • auto(デフォルト): オートネゴシエーション
  • no speed
    • 設定対象:device
    • 設定対象の Speed 設定をデフォルトに戻す
  • duplex duplex
    • 設定対象:device
    • 設定対象の Duplex を設定
    • duplex 選択肢
      • full:全二重通信
      • half:半二重通信
      • auto(デフォルト): オートネゴシエーション
  • no duplex
    • 設定対象:device
    • 設定対象の Duplex 設定をデフォルトに戻す

設定例:

device GigaEthernet1
  speed 100

#上は以下と同じ意味
device GigaEthernet1
  port 1 speed 100
  port 2 speed 100
  port 3 speed 100
  port 4 speed 100

#----------------------------------------

device GigaEthernet1
  duplex full

スイッチングハブである GigaEthernet1 に対して shutdown、speed および duplex などの設定を行うと、そのスイッチングハブのすべてのポートについて設定を行ったことと同じ意味になります。

コメント設定

  • description description
    • 設定対象:interface
    • インタフェースに対してコメント文を設定
    • description:コメント文
  • no description
    • コメントの削除

設定例:

interface GigaEthernet1.0
  description aaa bbb ccc ddd

VLAN 設定

VLAN インターフェースの作成(タグ VLAN)

VLAN インターフェースを作成する場合は、物理インターフェースに対してサブインターフェースを作成し、そのサブインターフェースに対してタグ ID を設定するという流れになります。

  • encapsulation dot1q tag-id [tpid tpid]
    • 設定対象:interface
    • tag-id:タグ ID。範囲 1~4095
    • tpid:VLAN TAG フィールドを識別する TPID 値。5dd~ffff(16進数で設定)
      • デフォルト 8100(16進数)

設定例:

Router(config)# interface GigaEthernet0.1  ← サブインターフェースを作成
Router(config-GigaEthernet0.1)# encapsulation dot1q 10  ← タグ ID を設定

設定を有効にするためには、設定保存後に IX2106 をリスタート (restart) する必要があります。

Router# write memory
Router# restart

ポートベース VLAN の設定

スイッチングハブのポートをグループ分けして、グループごとに異なるネットワークに接続することができます。

設定の流れは以下の通りです。

  1. VLAN グループの設定
  2. 各 VLAN グループの設定

VLAN グループを設定

設定はスイッチングハブのデバイスコンフィグモードで行います。

  • vlan-group GROUP port PORT [PORT [ … ]]
    • 設定対象:device(スイッチングハブ)
    • VLAN グループを作成
    • GROUP:グループ ID。1~4 (スイッチングハブのポート数) から指定 (複数可)
    • PORT:ポート番号。1~4 (スイッチングハブのポート数) から指定
  • no vlan-group GROUP [port PORT [ PORT [ … ]]]
    • VLAN グループの削除、または VLAN グループからポートを削除

設定例:

Router(config-GigaEthernet1)# vlan-group 1 port 1 2
Router(config-GigaEthernet1)# no vlan-group 1
Router(config-GigaEthernet1)# no vlan-group 1 port 2

VLAN グループの設定

VLAN グループの設定としては、以下の書式でインターフェースを指定した上でインターフェイスの設定を行います。

  • interface device:GROUP.sub-int-id
    • device:VLAN グループを作成したデバイスの名前(スイッチングハブ)
    • GROUP:VLAN グループ ID
    • sub-int-id:サブインターフェース 番号。0~32 から指定
      • タグ VLAN 用にサブインターフェースを追加する場合は 1~32 を指定する

設定例:デバイス GigaEthernet1 に対して作成した VLAN グループ 1 を設定する場合

Router(config)# interface GigaEthernet1:1.0
Router(config-GigaEthernet1:1.0)# ip address 10.0.1.1/24
Router(config-GigaEthernet1:1.0)# no shutdown

設定後、コンフィグ上では以下の様に表示されます。

Router(config)# show run
! NEC Portable Internetwork Core Operating System Software
! IX Series IX2106 (magellan-sec) Software, Version 10.2.16, RELEASE SOFTWARE
#略
device GigaEthernet1
  vlan-group 1 port 1
#略
interface GigaEthernet1:1.0
  ip address 10.0.1.1/24
  no shutdown

参考資料

VLAN : FAQ : UNIVERGE IXシリーズ | NEC
「UNIVERGE IXシリーズ」の「VLAN機能」に関するFAQページです。本製品は、IEEE802.1Q準拠のタグVLAN機能と、内蔵スイッチポートによるポートベースVLAN機能に対応しています。

―――――――――――――

タイトルとURLをコピーしました