【NEC UNIVERGE IX2106】PPPoE クライアントの設定方法

ネットワーク

作業環境

  • 型番:UNIVERGE IX2106
  • バージョン:10.2.16

PPPoE 設定例

ネットワーク構成

要件

クライアントA からクライアントB へ通信できるよう IX2106 にて PPPoE クライアントの設定を実施する。

なお、PPPoEサーバ (Cisco ルータを使用) のコンフィグとして以下を設定している前提とします。

username pppoe@example.com password hogehoge

bba-group pppoe PPPOE-GROUP1
 virtual-template 1

interface GigabitEthernet8
 ip address 120.130.140.254 255.255.255.0
 duplex auto
 speed auto
 pppoe enable group PPPOE-GROUP1

interface Virtual-Template1
 mtu 1454
 ip unnumbered GigabitEthernet8
 peer default ip address pool POOL1
 ppp authentication chap

ip local pool POOL1 120.130.140.1

※GigabitEthernet8 は IX2106 と接続しているポート

PPPPoE クライアント設定

ppp プロファイル設定

PPPoE の認証情報を定義します。

ppp profile profile-1
  authentication myname pppoe@example.com
  authentication password pppoe@example.com hogehoge
  • authentication myname pppoe@example.com
    • ユーザ名の設定。pppoe@example.com と設定している
  • authentication password pppoe@example.com hogehoge
    • ユーザ名に対応するパスワードの設定。ユーザ名 pppoe@example.com に対してパスワードを hogehoge と設定している

pppoe 用サブインターフェースの設定

PPPoE 接続用のサブインターフェースを作成し、設定します。例では GigaEthernet0.1 を作成しています。

interface GigaEthernet0.0
  ip address 10.200.1.254/24
  no shutdown

interface GigaEthernet0.1
  encapsulation pppoe
  auto-connect
  ppp binding profile-1
  ip address ipcp
  ip napt enable
  no shutdown
  • encapsulation pppoe
    • PPPoE を有効化
  • auto-connect
    • 装置起動直後に接続を開始
  • ppp binding profile-1
    • PPPoE プロファイルとして profile-1 を指定している
  • ip address ipcp
    • IPCP で受理した自動割当アドレスを利用する
  • ip napt enable
    • アドレス変換として NAPT を使用
  • no shutdown
    • インターフェースを有効化

ルーティングの設定

外部向けのスタティックルートを設定します。出力インターフェースを PPPoE 接続用のサブインターフェースとして設定します。

ip route 200.1.1.0/24 GigaEthernet0.1

PPPoE インターフェースの IP アドレスの確認

show ip address で PPPoE インターフェースの IP アドレスを取得できていることを確認します。

Router(config)# show ip address 
#略
Interface GigaEthernet0.1 is up, line protocol is up
  Internet address is 120.130.140.1/32
  Broadcast address is 255.255.255.255
  Peer address is 120.130.140.254
  Address determined by IPCP
#略

PPPoE 状態の表示コマンド

show pppoe status で PPPoE の状態を表示できます。

Router(config)# show pppoe status
Interface GigaEthernet0.1 is up
  Control status:
    State is established
    Previous state is PADS wait
    Time since change 44 minutes and 36 seconds
    Host unique tag: 01968178
    Connected access concentrator is RT02
  Statistics:
    PADI: 1 outputs, 0 retries
    PADO: 1 inputs
    PADR: 1 outputs, 0 retries
    PADS: 1 inputs
    PADT: 0 inputs, 0 outputs, 0 timeouts
    0 input discards, 0 output discards

―――――――――――――

タイトルとURLをコピーしました