【NEC QX スイッチ】インターフェース基本設定

ネットワーク

作業環境

  • QX-S1008GT-2G Version 5.2.11

インターフェースのデフォルト設定

interface GigabitEthernet1/0/x
 loopback-detection enable
 undo dot1x handshake
 undo dot1x multicast-trigger
 dot1x unicast-trigger
  • loopback-detection enable
    • ループバック検知機能を有効化しています
    • この設定だけでは特に動作には影響しません
  • undo dot1x handshake
    • オンラインユーザハンドシェイク機能を無効にしています
    • これが有効の場合、定期的にユーザがオンラインであるかをチェックするため、装置からクライアントにハンドシェイクメッセージを送信します
  • undo dot1x multicast-trigger
    • 802.1X マルチキャストトリガ機能を無効にしています
    • 802.1X マルチキャストトリガ機能は、装置がイニシエータとして動作することを有効にします
      • 802.1X クライアントを検出し、認証を開始するため、定期的に EAP 要求パケットをマルチキャストします
  • dot1x unicast-trigger
    • 802.1X のユニキャストトリガ機能を有効にしています
    • 802.1X ユニキャストトリガ機能は、未知の送信元 MAC アドレスからデータフレームを受信したときに 802.1X 認証を開始する機能です
    • 機器から unicast EAP/Request パケットを未知の送信元の MAC アドレスに送信しますが、一定時間内(dot1x timer tx-period)に反応がない場合、dot1x retry で設定された最大数までパケットを再送します

各種インターフェース基本設定

説明文の設定

  • description <text>
    • 80 文字以内で説明文を設定

Duplex の設定

  • duplex <duplex>
    • 以下から duplex を指定
      • auto(デフォルト)
      • full
      • half

Speed の設定

  • speed <speed>
    • 以下から speed を指定
      • 10
      • 100
      • 1000
      • auto(デフォルト)

インターフェースの無効化/有効化

  • shutdown
    • 無効化
  • undo shutdown
    • 有効化

ストームコントロール設定

ブロードキャスト、マルチキャスト、ユニキャストそれぞれについて、トラフィック量がしきい値を超えている場合、しきい値を下回るまでパケットを廃棄します。

■ブロードキャストパケットの制御

  • broadcast-suppression <1-100>
    • 帯域に対するパーセンテージで指定する場合
  • broadcast-suppression pps <1-260000>
    • 毎秒のパケットの最大数で指定する場合(パケット/秒)
  • broadcast-suppression kbps <1-180000>
    • 毎秒のトラフィックの最大帯域で指定する場合(キロビット/秒)
    • 設定された値が 32 よりも小さい場合、32 の値が適用されます
    • 設定された値が 32 の整数倍より大きく、32 の整数倍でない場合、設定された 32 の整数倍にもっとも近い値が適用されます

■マルチキャストパケットの制御

  • multicast-suppression <1-100>
  • multicast-suppression pps <1-260000>
  • multicast-suppression kbps <1-180000>

※各指定方式の説明はブロードキャストと同様

■ユニキャストパケットの制御

  • unicast-suppression <1-100>
  • unicast-suppression pps <1-260000>
  • unicast-suppression kbps <1-180000>

※各指定方式の説明はブロードキャストと同様

ポートベース Vlan の設定

Vlan ID の作成

  • vlan <Vlan-ID>
[QX-S1008GT-2G]vlan 110
[QX-S1008GT-2G-vlan110]

ポートタイプの設定

対象のインターフェース view にて以下コマンドで設定します。

  • port link-type <type>
    • <type> は以下から指定
      • access(デフォルト)→ アクセスポートに設定する
      • hybrid → ハイブリッドポートに設定する
      • trunk → トランクポート(タグ Vlan)に設定する
[QX-S1008GT-2G-GigabitEthernet1/0/1]port link-type trunk

アクセスポートの設定

Vlan view で設定する場合

  • port <port-list>
[QX-S1008GT-2G]vlan 110
[QX-S1008GT-2G-vlan110]port GigabitEthernet 1/0/8

Interface view で設定する場合

  • port access vlan <Vlan-ID>
[QX-S1008GT-2G]interface GigabitEthernet1/0/8
[QX-S1008GT-2G-GigabitEthernet1/0/8] port access vlan 110

トランクポートの設定

許可 Vlan ID の設定

  • port trunk permit vlan <vlan-list>
    • 通信許可する Vlan ID リストを指定
      • 複数指定 → 10 20 30 40
      • 範囲指定 → 30 to 40
      • すべての Vlan → all
    • デフォルトは Vlan 1 のみ許可
    • 既存の 許可 Vlan ID 設定が存在する場合に再度この設定コマンドを実行すると、設定が上書きされるのではなく対象 Vlan ID が追加される
[QX-S1008GT-2G-GigabitEthernet1/0/1]display current-configuration interface GigabitEthernet 1/0/1
#
interface GigabitEthernet1/0/1
 port link-type trunk
 port trunk permit vlan 1
 loopback-detection enable
 undo dot1x handshake
 undo dot1x multicast-trigger
#
return
[QX-S1008GT-2G-GigabitEthernet1/0/1]
[QX-S1008GT-2G-GigabitEthernet1/0/1]port trunk permit vlan 10 20
 Please wait... Done.
[QX-S1008GT-2G-GigabitEthernet1/0/1]display current-configuration interface GigabitEthernet 1/0/1
#
interface GigabitEthernet1/0/1
 port link-type trunk
 port trunk permit vlan 1 10 20
 loopback-detection enable
 undo dot1x handshake
 undo dot1x multicast-trigger
#
return
[QX-S1008GT-2G-GigabitEthernet1/0/1]

PVID(ネイティブ Vlan)の設定

  • port trunk pvid vlan <vlan-id>
    • デフォルトは 1
[QX-S1008GT-2G-GigabitEthernet1/0/1]port trunk pvid vlan 30

Vlan インターフェースの設定

■Vlan インターフェース設定 View への移行

  • interface Vlan-interface <Vlan-ID>

■IP アドレスの設定

  • ip address <address> <mask>
  • ip address <address> <mask-length>
[QX-S1008GT-2G]interface Vlan-interface 110
[QX-S1008GT-2G-Vlan-interface110]ip address 10.1.100.1 255.255.255.0

確認コマンド

インターフェース

  • display interface [<interface-name>]
[QX-S1008GT-2G]display interface GigabitEthernet 1/0/8
 GigabitEthernet1/0/8 current state: UP
 IP Packet Frame Type: PKTFMT_ETHNT_2, Hardware Address: 38ad-8eb7-ed87
 Description: GigabitEthernet1/0/8 Interface
 Loopback is not set
 Media type is twisted pair, Port hardware type is 1000_BASE_T
 1000Mbps-speed mode, full-duplex mode
 Link speed type is autonegotiation, link duplex type is autonegotiation
 Flow-control is not enabled
 The Maximum Frame Length is 9600
 Broadcast MAX-ratio: 100%
 Unicast MAX-ratio: 100%
 Multicast MAX-ratio: 100%
 PVID: 110
 Mdi type: auto
 Port link-type: access
  Tagged   VLAN ID : none
  Untagged VLAN ID : 110
 Port priority: 0
 Last clearing of counters:  Never
 Peak value of input: 346 bytes/sec, at 2000-04-27 11:18:28
 Peak value of output: 53 bytes/sec, at 2000-04-27 12:17:48
 Last 300 seconds input:  0 packets/sec 142 bytes/sec 0%
 Last 300 seconds output:  0 packets/sec 50 bytes/sec 0%
 Input (total):  1580 packets, 347732 bytes
         152 unicasts, 520 broadcasts, 908 multicasts, 0 pauses
 Input (normal):  1580 packets, 347732 bytes
         152 unicasts, 520 broadcasts, 908 multicasts, 0 pauses
 Input:  0 input errors, 0 runts, - giants, - throttles
         0 CRC, - frame, 0 overruns, 0 aborts
         - ignored, - parity errors
 Output (total): 1099 packets, 77705 bytes
         114 unicasts, 985 broadcasts, 0 multicasts, 0 pauses
 Output (normal): 1099 packets, 77705 bytes
         114 unicasts, 985 broadcasts, 0 multicasts, 0 pauses
 Output: 0 output errors, - underruns, - buffer failures
         0 aborts, 0 deferred, 0 collisions, - late collisions
         - lost carrier, - no carrier
  • display interface brief
[QX-S1008GT-2G]display interface brief
The brief information of interface(s) under route mode:
Link: ADM - administratively down; Stby - standby
Protocol: (s) - spoofing
Interface            Link Protocol Main IP         Description
NULL0                UP   UP(s)    --
Vlan110              UP   UP       10.1.100.1

The brief information of interface(s) under bridge mode:
Link: ADM - administratively down; Stby - standby
Speed or Duplex: (a)/A - auto; H - half; F - full
Type: A - access; T - trunk; H - hybrid
Interface            Link Speed   Duplex Type PVID Description
GE1/0/1              DOWN auto    A      A    1
GE1/0/2              DOWN auto    A      A    1
GE1/0/3              DOWN auto    A      A    1
GE1/0/4              DOWN auto    A      A    1
GE1/0/5              DOWN auto    A      A    1
GE1/0/6              DOWN auto    A      A    1
GE1/0/7              DOWN auto    A      A    1
GE1/0/8              UP   1G(a)   F(a)   A    110
GE1/0/9              DOWN auto    A      A    1
GE1/0/10             DOWN auto    A      A    1

Vlan

  • display vlan
[QX-S1008GT-2G]display vlan
 Total 2 VLAN exist(s).
 The following VLANs exist:
  1(default), 110,
  • display vlan all
[QX-S1008GT-2G]display vlan all
 VLAN ID: 1
 VLAN Type: static
 Route Interface: not configured
 Description: VLAN 0001
 Name: VLAN 0001
 Tagged   Ports: none
 Untagged Ports:
    GigabitEthernet1/0/1     GigabitEthernet1/0/2     GigabitEthernet1/0/3
    GigabitEthernet1/0/4     GigabitEthernet1/0/5     GigabitEthernet1/0/6
    GigabitEthernet1/0/7     GigabitEthernet1/0/9     GigabitEthernet1/0/10

 VLAN ID: 110
 VLAN Type: static
 Route Interface: configured
 IPv4 address: 10.1.100.1
 IPv4 subnet mask: 255.255.255.0
 Description: VLAN 0110
 Name: VLAN 0110
 Tagged   Ports: none
 Untagged Ports:
    GigabitEthernet1/0/8

―――――――――――――

タイトルとURLをコピーしました